Apr 132014
 

As you should know by now CentOS uses Yum to install and update packages but sometime you need packages that are not available as standard, one way to get these packages is to use 3rd party repositories which is what i do.

A note on CentOS packages
“As with all packages in CentOS, the version numbers of released software will not change over the life time of a CentOS product, i.e. CentOS 5.0 contained PHP 5.1.6 and that is the point version PHP will stay at for the life time of CentOS 5. Security patches and bug fixes are back-ported into the shipped version. See here for details: Backporting Security Fixes

You can get a list of 3rd party repositories here.
I mainly use the following extra repositories, Remi Collet Repository which also requires Extra Packages for Enterprise Linux (EPEL).

If you are considering using a 3rd Party Repository, then you should seriously consider how to prevent unintended ‘updates’ from these side archives from over-writing some core part of CentOS. One approach is to only enable these archives from time to time, and generally leave them disabled.

The Remi repository has a page detailing how to setup and use their repository.
Scroll down the page until you find “Enterprise Linux 6 (with EPEL)” and follow the instructions
here’s the quick version but check for updates

wget http://dl.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
rpm -Uvh remi-release-6*.rpm epel-release-6*.rpm

This will install both repository’s (remi and epel). The repository’s are not enabled when install (enabled=0). You need to enable them when you need it, for example
yum --enablerepo=remi install php*

One last note, always test everything (preferable not on a live production machine) and ensure you have a backup when using 3rd party packages as sometime a simple update can have very bad side effects.

799 total views, 1 views today

Sorry, the comment form is closed at this time.